Networking Requirements

As shown in Figure 1, two routers, PE1 and PE2, are PEs to be enabled with the VPLS function. CE1 is connected with PE1, while CE2 is connected with PE2. CE1 and CE2 belong to the same VPLS. After the VPLS configuration, interworking between CE1 and CE2 is available.
In the network, construct a VPLS VPN for CE1 and CE2 and adopt the LDP as the VPLS signaling to establish the PW.
Figure 1 Martini VPLS 

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure the routing protocol on the backbone network.
  2. Set up the remote LDP session between PEs.
  3. Set up the tunnel used to transmit the user data between PEs.
  4. Enable the MPLS L2VPN on the PE.
  5. Create the VSI on the PE. Specify the signaling as LDP and then bind the VSI with the AC interface.

Data Preparation

To configure the Martini VPLS, you need the following data:
  • VSI name and VSI ID
  • IP address and tunnel policy used in setting up the peer
  • Interface bound to the VSI

Procedure

  1. Configure OSPF.
    Configure the IP addresses of the PE and P as shown in Figure 1. When configuring OSPF, configure OSPF to advertise the 32-bit address of the loopback interface (LSR-ID) of the PE1, P and PE2.
    After the configuration, run the display ip routing-table command on PE1, P and PE2. The output shows that PE1 and PE2 know each other’s routing information.
    For the details on the configuration of the OSPF in this instance, see the following Configuration Files.
  2. Configure basic MPLS capability and LDP.
    For the detailed procedure of the configuration, see the following Configuration Files.
    Run the display mpls ldp session command on PE1 and PE2, and you can see that LDP sessions are established between the peers. Run thedisplay mpls lsp command, and you can see the information of established LSPs.
  3. Configure remote session of LDP.
    # Configure PE1.
    [PE1] mpls ldp remote-peer 3.3.3.9
    [PE1-mpls-ldp-remote-pe2] remote-ip 3.3.3.9
    [PE1-mpls-ldp-remote-pe2] quit
    # Configure PE2.
    [PE2] mpls ldp remote-peer 1.1.1.9
    [PE2-mpls-ldp-remote-pe1] remote-ip 1.1.1.9
    [PE2-mpls-ldp-remote-pe1] quit
    After the configuration, run the display mpls ldp session command on PE1 or PE2, and you can find the status of the peers PE1 and PE2 is “operational”. That is, the remote peer relationship is set up.
  4. Enable MPLS L2VPN on PEs.
    # Configure PE1.
    [PE1] mpls l2vpn
    # Configure PE2.
    [PE2] mpls l2vpn
  5. Configure a VSI on each PE.
    # Configure PE1.
    [PE1] vsi a2 static
    [PE1-vsi-a2] pwsignal ldp
    [PE1-vsi-a2-ldp] vsi-id 2
    [PE1-vsi-a2-ldp] peer 3.3.3.9
    # Configure PE2.
    [PE2] vsi a2 static
    [PE2-vsi-a2] pwsignal ldp
    [PE2-vsi-a2-ldp] vsi-id 2
    [PE2-vsi-a2-ldp] peer 1.1.1.9
  6. Bind the VSI with the AC interface on PE.
    # Configure PE1.
    [PE1] interface gigabitethernet1/0/0.1
    [PE1-GigabitEthernet1/0/0.1] shutdown
    [PE1-GigabitEthernet1/0/0.1] vlan-type dot1q 10
    [PE1-GigabitEthernet1/0/0.1] l2 binding vsi a2
    [PE1-GigabitEthernet1/0/0.1] undo shutdown
    # Configure PE2.
    [PE2] interface gigabitethernet2/0/0.1
    [PE2-GigabitEthernet2/0/0.1] shutdown
    [PE2-GigabitEthernet2/0/0.1] vlan-type dot1q 10
    [PE2-GigabitEthernet2/0/0.1] l2 binding vsi a2
    [PE2-GigabitEthernet2/0/0.1] undo shutdown
  7. Configure the CEs.
    # Configure CE1.
    <HUAWEI> sysname CE1
    [CE1] interface gigabitethernet1/0/0.1
    [CE1-GigabitEthernet1/0/0.1] shutdown
    [CE1-GigabitEthernet1/0/0.1] vlan-type dot1q 10
    [CE1-GigabitEthernet1/0/0.1] ip address 10.1.1.1 255.255.255.0
    [CE1-GigabitEthernet1/0/0.1] undo shutdown
    # Configure CE2.
    <HUAWEI> sysname CE2
    [CE2] interface gigabitethernet1/0/0.1
    [CE2-GigabitEthernet1/0/0.1] shutdown
    [CE2-GigabitEthernet1/0/0.1] vlan-type dot1q 10
    [CE2-GigabitEthernet1/0/0.1] ip address 10.1.1.2 255.255.255.0
    [CE2-GigabitEthernet1/0/0.1] undo shutdown
  8. Verify the configuration.
    After the configuration, run the display vsi name a2 verbose command on PE1, and you can see that VSI named a2 establishes a PW to PE2 and the VSI is Up.
    <PE1> display vsi name a2 verbose
    
    
     ***VSI Name               : a2
        Administrator VSI      : no
        Isolate Spoken         : disable
        VSI Index              : 0
        PW Signaling           : ldp
        Member Discovery Style : static
        PW MAC Learn Style     : unqualify
        Encapsulation Type     : vlan
        MTU                    : 1500
        Diffserv Mode          : uniform
        Service Class          : --
        Color                  : --
        DomainId               : 0
        Domain Name            :
        Ignore AcState         : disable
        Create Time            : 0 days, 3 hours, 30 minutes, 31 seconds
        VSI State              : up
    
    
        VSI ID                 : 2
       *Peer Router ID         : 3.3.3.9
        VC Label               : 23552
        Peer Type              : dynamic
        Session                : up
        Tunnel ID              : 0x2002001,
        Broadcast Tunnel ID    : 0x2002001                                           
    CKey : 6
    NKey : 5
    StpEnable : 0
    PwIndex : 0
    
    
        Interface Name         : GigabitEthernet1/0/0.1
        State                  : up
        Last Up Time           : 2008-08-15 15:41:59
        Total Up Time          : 0 days, 0 hours, 1 minutes, 2 seconds
    
    
       **PW Information:
    
    
       *Peer Ip Address        : 3.3.3.9
        PW State               : up
        Local VC Label         : 23552
        Remote VC Label        : 23552
        PW Type                : label
        Tunnel ID              : 0x2002001,
        Broadcast Tunnel ID    : 0x2002001                        
    Ckey : 0x6
    Nkey : 0x5
    Main PW Token : 0x801008
    Slave PW Token : 0x0
    Tnl Type : LSP
    OutInterface : Pos1/0/0
    Stp Enable : 0
    Mac Flapping : 0
        PW Last Up Time        : 2008-08-15 15:41:59
        PW Total Up Time       : 0 days, 0 hours, 1 minutes, 3 seconds
    CE1 (10.1.1.1) can ping through CE2 (10.1.1.2).
    <CE1> ping 10.1.1.2
      PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=90 ms
        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=77 ms
        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=34 ms
        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=46 ms
        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=94 ms
      --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 34/68/94 ms

Configuration Files

  • Configuration file of CE1
    #
     sysname CE1
    #
    interface GigabitEthernet1/0/0
    undo shutdown
    #
    interface GigabitEthernet1/0/0.1
     undo shutdown
     vlan-type dot1q 10
     ip address 10.1.1.1 255.255.255.0
    #
    return
  • Configuration file of CE2
    #
     sysname CE2
    #
    interface GigabitEthernet1/0/0
    undo shutdown
    #
    interface GigabitEthernet1/0/0.1
     undo shutdown
     vlan-type dot1q 10
     ip address 10.1.1.2 255.255.255.0
    #
    return
  • Configuration file of PE1
    #
     sysname PE1
    #
     mpls lsr-id 1.1.1.9
     mpls
    #
     mpls l2vpn
    #
    vsi a2 static 
     pwsignal ldp 
      vsi-id 2    
      peer 3.3.3.9
    # 
    mpls ldp
    #
     mpls ldp remote-peer 3.3.3.9
     remote-ip 3.3.3.9
    #
    interface GigabitEthernet1/0/0
    undo shutdown
    #
    interface GigabitEthernet1/0/0.1
     undo shutdown
     vlan-type dot1q 10
     l2 binding vsi a2
    #
    interface Pos2/0/0
     link-protocol ppp
     undo shutdown
     ip address 168.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 168.1.1.0 0.0.0.255
    #
    return
  • Configuration file of P
    #
     sysname P
    #
     mpls lsr-id 2.2.2.9
     mpls
    #
    mpls ldp
    #
    interface Pos1/0/0
     link-protocol ppp
     undo shutdown
     ip address 168.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Pos2/0/0
     link-protocol ppp
     undo shutdown
     ip address 169.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 168.1.1.0 0.0.0.255
      network 169.1.1.0 0.0.0.255
      network 2.2.2.9 0.0.0.0
    #
    return
  • Configuration file of PE2
    #
     sysname PE2
    #
     mpls lsr-id 3.3.3.9
     mpls
    #
     mpls l2vpn
    #
    vsi a2 static  
     pwsignal ldp  
      vsi-id 2     
      peer 1.1.1.9 
    # 
    mpls ldp
    #
     mpls ldp remote-peer 1.1.1.9
     remote-ip 1.1.1.9
    #
    interface Pos1/0/0
     link-protocol ppp
     undo shutdown
     ip address 169.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
    undo shutdown
    #
    interface GigabitEthernet2/0/0.1
     undo shutdown
     vlan-type dot1q 10
     l2 binding vsi a2
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 169.1.1.0 0.0.0.255
    #
    return

from the best of networking http://ift.tt/1G8Hgp8

(Visited 2,513 times, 1 visits today)

1 Comment

  1. ali

    vsi command is not working on any router which came by default with simulator
    what is the solution

Leave a Reply

Your email address will not be published.